Corvair DiagramCorvair Photo
Corvair Center
home forum corvairs calendar links Corvair Podcast
California Corvairs
Clarks Corvair
Clarks Corvair
“CORSA"



Chevy Corvair License Plate
Chevy Corvair Chrome Wheel
Corvair Center Forum :  Corvair Center Phorum The fastest message board... ever.
Corvair Center 
Idle problems / New Member
Posted by: Monza ()
Date: June 09, 2018 07:12AM

Hello everyone, I'm fairly new to the corvair community. I just bought a 1965 monza 140. At some point long ago someone was fooling around with it. They put headers on it, a holley 4160 carburetor that's 390cfm. Holley electronic fuel pump and pressure regulator, and an ignitor 2 ignition system. The gentleman I bought it from had it running, but couldn't get it to idle. I already rebuilt the carburetor, changed the oil, cleaned out the fuel system and installed new fuel filters. I'm still having the same problem he did.



Edited 2 time(s). Last edit at 06/09/2018 07:38AM by MattNall.

Options: ReplyQuote
Re: Idle problems
Posted by: MattNall ()
Date: June 09, 2018 07:20AM

Welcome to the CCF!

Please tell us where you are! This type of problem needs someone with Corvair / Holley experience.

How are you timing the engine? It needs to be done statically..... I would remove the Pet II and go back to points until you get it running correctly.

This combination will work...been in use for decades..

To get a Holley to idle.... best to back the idle speed off all the way.... Choke open... Engine warm...

Then test.... no idle... Turn screw in 1 turn CW... test again... repeat until it stays running.





MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote
Re: Idle problems
Posted by: Wagon Master ()
Date: June 09, 2018 07:21AM

At what RPM are you trying to get it to idle at?
Consider swapping out the Petronix for a point plate as a test.


'64 Monza Coupe 140 4 speed
'61 700 Lakewood 95 4 speed
'69 Monza Convert. 140 Auto.

Been aircooled since 1973
Northwest Ohio

Options: ReplyQuote
Re: Idle problems / New Memeber
Posted by: MattNall ()
Date: June 09, 2018 07:23AM

And what Transmission.... PII's do not work well with a PG at idle.....





MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote
Re: Idle problems
Posted by: Monza ()
Date: June 09, 2018 11:29AM

I'm in Rome Georgia. I have a 4 speed manual transmission. I'm shooting for around 500rpm at idle.

Options: ReplyQuote
Re: Idle problems
Posted by: MattNall ()
Date: June 09, 2018 11:31AM

500... then the PII is your problem...

set it for 800 rpm and see if it's stable.


PII drops cylinders at super low RPM... known problem..





MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo




Edited 1 time(s). Last edit at 06/09/2018 11:32AM by MattNall.

Options: ReplyQuote
Re: Idle problems / New Member
Posted by: Monza ()
Date: June 09, 2018 11:44AM

I'll give it a try.

Options: ReplyQuote
Re: Idle problems / New Member
Posted by: Monza ()
Date: June 09, 2018 11:46AM

What's the best timing to run these engines at? Mine's a 140 hp that originally had the 4 carburetor set up.

Options: ReplyQuote
Re: Idle problems / New Member
Posted by: MattNall ()
Date: June 09, 2018 11:49AM

650-800 rpm .. with 16-18 degrees BTDC..
With Vacuum advance disconnected!

Engine should not speed up when idling and you re-connect hose!

Free Digital copies of Manuals are available in out STICKY FAQ's.





MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote
Re: Idle problems / New Member
Posted by: Monza ()
Date: July 08, 2018 05:42PM

Problem solved. Holley had a clogged metering block. Thanks for the help everyone.

Options: ReplyQuote
Re: Idle problems / New Member
Posted by: MattNall ()
Date: July 08, 2018 05:45PM

Great news!! drive on!


How low can you get the idle now?





MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.