Corvair DiagramCorvair Photo
Corvair Center
home forum corvairs calendar links Corvair Podcast
California Corvairs
Clarks Corvair
American Flat 6


Chevy Corvair License Plate
Chevy Corvair Chrome Wheel
Corvair Center Forum :  Corvair Center Phorum The fastest message board... ever.
Corvair Center 
Pages: Previous12
Current Page: 2 of 2
Re: New fuel sender... A/C work done... Car not running right.
Posted by: bentley26 ()
Date: March 06, 2012 02:17AM

One other note... When I removed the fuel inlet nut on carb #2, a fair amount of gas liberated itself from the carb. This did not happen with the first one. Any significance?

As for the driving, when I hit the gas at low speed, it almost seems like the engine stops running for a moment... One second you hear the rumble from the exhaust, then you don't for the next few.

Sorry for all of the posts... Just trying to identify the issue before I determine whether or not I need to enlist the help of a mechanic. After the cost of an R12 charge on the AC, I'd love to save some $$$. Thanks!!!

Christopher
1965 Monza Sedan 110 "Air Vair."

Fort Collins, CO

Options: ReplyQuote
Re: New fuel sender... A/C work done... Car not running right.
Posted by: MattNall ()
Date: March 06, 2012 02:52AM

AHH.. the other carb is flooding!!... inlet valve does not shut off..





MODERATOR
Somewhere between Sea Mountain and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
.............................PG...................................Turbo

Options: ReplyQuote
Re: New fuel sender... A/C work done... Car not running right.
Posted by: bentley26 ()
Date: March 06, 2012 02:58AM

Ah ha... So, what is the remedy. Need to take the carb apart and clean? That would be something I've not attempted before.

Christopher
1965 Monza Sedan 110 "Air Vair."

Fort Collins, CO

Options: ReplyQuote
Re: New fuel sender... A/C work done... Car not running right.
Posted by: MattNall ()
Date: March 06, 2012 03:01AM

Correct.... and you can test when apart....

hold the top in your hand and push up on the float...closing the inlet valve

Blow in the fuel line... you should not hear any leakage...

if you do.. clean and retest... or replace.





MODERATOR
Somewhere between Sea Mountain and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
.............................PG...................................Turbo

Options: ReplyQuote
Re: New fuel sender... A/C work done... Car not running right.
Posted by: bentley26 ()
Date: March 06, 2012 03:42AM

Thanks again, Matt. Is this a fix you'd suggest someone new to carburetors attempt, or find a pro? Don't mind getting my hands dirty, but don't want to cause more harm than good.

Christopher
1965 Monza Sedan 110 "Air Vair."

Fort Collins, CO

Options: ReplyQuote
Re: New fuel sender... A/C work done... Car not running right.
Posted by: MattNall ()
Date: March 06, 2012 03:54AM

Exploded view is in our FAQ's..

Do not bend any part!! you'll be fine!





MODERATOR
Somewhere between Sea Mountain and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
.............................PG...................................Turbo

Options: ReplyQuote
Re: New fuel sender... A/C work done... Car not running right.
Posted by: bentley26 ()
Date: March 06, 2012 04:51PM

Last question... I am guessing I'll want a rebuild kit on-hand before I dive into this. I see several available from Clarks. The carbs were both professionally cleaned/rebuilt about 18 months ago... Knowing that is there a set recommended for this project? (Gasket only, Minor, Deluxe, Super Delux.)

Thanks again... Wouldn't have gotten this far without all of the help!

Christopher
1965 Monza Sedan 110 "Air Vair."

Fort Collins, CO

Options: ReplyQuote
Re: New fuel sender... A/C work done... Car not running right.
Posted by: Yenkos66 ()
Date: March 06, 2012 05:21PM

Autozone should carry a basic rebuild get. It's the one I always use.

Alex Moats
Wichita KS
68 500 140 4spd
68 500 110 3spd
Duane Grimm always remembered rip

Options: ReplyQuote
Re: New fuel sender... A/C work done... Car not running right.
Posted by: bentley26 ()
Date: March 21, 2012 05:15PM

Update... The passanger-side carb has been removed, cleaned and put back in the car. Noticed upon disassembly the pin (hinge?) was missing, so I am sure that didn't help. Must have been that way since its last rebuild in early 2010!

Car is running better now, but still trouble with timing. Further investigation suggests the distributor is in need of refresh (weight springs are shot). Swapping a rebuilt one in today. Hopefully this does the trick!

Next up... Replacing the rear engine mount. Looks bad enough it's starting to draw unsolicited comments regarding its condition.

Thanks all for your help!

Chris

Christopher
1965 Monza Sedan 110 "Air Vair."

Fort Collins, CO

Options: ReplyQuote
Pages: Previous12
Current Page: 2 of 2


Sorry, only registered users may post in this forum.
This forum powered by Phorum.