Corvair DiagramCorvair Photo
Corvair Center
home forum corvairs calendar links Corvair Podcast
California Corvairs
Clarks Corvair
Clarks Corvair
“CORSA"



Chevy Corvair License Plate
Chevy Corvair Chrome Wheel
Corvair Center Forum :  Corvair Center Phorum The fastest message board... ever.
Corvair Center 
Pages: Previous12
Current Page: 2 of 2
Re: Powerglide Problems
Posted by: TerribleTed ()
Date: June 28, 2019 06:08PM

I have had a cable stretch (aftermarket repro replacement). It does not stop the trans from operating correctly it just screws up the indicated position at the dash as in it will start in drive when neutral is indicated and if bad enough it may be impossible to select reverse.

---------------------------------------------------------------------------------------------------------

Avid Corvair hobbiest since 1984.
I have personally performed ground up restoration on over 20 Corvairs.
I currently work full time at restoring and repairing Corvairs.
Located in the Atlanta Georgia area.
[www.facebook.com]

Options: ReplyQuote
Re: Powerglide Problems
Posted by: guthrie1068 ()
Date: July 01, 2019 06:37PM

I just wanted to say thanks for this posting, I had the pan off mine yesterday and found mine was out of adjustment. Made the adjustment with the help of the pics in this post with ease. I have another question now, there was a lot of black oily substance in my pan, and I wonder if anyone knows what it could be? Is it a sign of something wrong, or is it a sign that someone put something in there that shouldn't have been in there?

Chad Guthrie
Onondaga, MI
'63 convertible

Options: ReplyQuote
Re: Powerglide Problems
Posted by: MattNall ()
Date: July 01, 2019 06:40PM

A sign of use..... Chunks are what you worry about!

MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote
Re: Powerglide Problems
Posted by: billyst.louis ()
Date: July 07, 2019 06:45PM

Okay, once again thanks for all of the help from everyone. Here's a quick update, I adjusted the low band again. I am still not sure how exact the adjustment is, but I read that the correct inch pounds should be roughly as tight as a person can turn it in with a screwdriver. I then adjusted it 4 whole turns out and tightened the retaining nut. I started the car and gave it some gas...the car drove forward. The shift lever was in NEUTRAL, but the car moved forward, not a creep or a crawl, it drove forward. I shifted the lever into neutral, the car stopped abruptly but did not move backward either. However, the idle (rough as it was) did not ramp up like the car was in neutral and I cannot push the car in any direction so I do not believe that I am in NEUTRAL. Still dumbfounded...

Options: ReplyQuote
Re: Powerglide Problems
Posted by: junkman ()
Date: July 07, 2019 09:41PM

Call the rebuilder, and ask them for a replacement. Do this now, before a bunch of months go by and it is out of warrantee... You did get some type of warrantee with it

---------------------------------------------------------------------------------------------------------------
Woodstock CT... Located on the Connecticut / Massachusetts border, approximately 6 miles from the center of Southbridge MA. About 45 minutes from Hartford CT. 1 1/2 hours West of Boston MA. Woodstock CT to Los Angeles CA 2,937.1 miles. 1 Mile as the crow flies to Big Bird's nest.

Options: ReplyQuote
Re: Powerglide Problems
Posted by: Wagon Master ()
Date: July 08, 2019 06:19AM

billyst.louis Wrote:
-------------------------------------------------------
The shift lever was in NEUTRAL, but the car moved forward, not a creep or a crawl, it drove forward. I shifted the lever into neutral, the car stopped abruptly but did not move backward either. I cannot push the car in any direction so I do not believe that I am in NEUTRAL. Still dumbfounded...

Forgive my confusion but.......
1. How did you shift the car into neutral when it was already in NEUTRAL?

2. When my car is OFF with the parking brake released, I can roll it forward or backwards in any dash shifter position, Drive, Low Neutral, Reverse. Are all 4 of your brakes releasing?

If so, something is bound up or not releasing inside your trans. Time to get your rebuilder involved.

Options: ReplyQuote
Re: Powerglide Problems
Posted by: Timothy Shortle ()
Date: July 08, 2019 08:58AM

Transmission was rebuilt 3 months ago by a reputable source? Was a warranty provided at the time work was done? Why are you going thru all this? Shouldn't
the person that got paid to rebuild it be informed of your issues?

Options: ReplyQuote
Re: Powerglide Problems
Posted by: cnicol ()
Date: July 08, 2019 08:49PM

Did you set the running clearance (shim pack) when you installed the trans? If the running clearance is too tight some of the clutches can't open and disengage.

Craig N. Coeur d'Alene ID.
66 Black Monza 4dr, 4.2L V8 49k
61 Seamist Jade Rampside 140 PG
60 Monza coupe (sold, sniff sniff)
66 Sprint Corsa convt - First car! Re-purchased 43 years later
2+2 gnatsuM 5691

+17 Tons of parts

Options: ReplyQuote
Pages: Previous12
Current Page: 2 of 2


Sorry, only registered users may post in this forum.
This forum powered by Phorum.