Corvair DiagramCorvair Photo
Corvair Center
home forum corvairs calendar links Corvair Podcast
California Corvairs
Clarks Corvair
Clarks Corvair
“CORSA"



Chevy Corvair License Plate
Chevy Corvair Chrome Wheel
Corvair Center Forum :  Corvair Center Phorum The fastest message board... ever.
Corvair Center 
Shes finally on the road! with other problems....
Posted by: AKcorvair ()
Date: June 10, 2019 10:10PM

After Finally getting the 3 speed Transmission on my 1964 corvair rebuilt. Im finally enjoying driving the car!


some problems i have encountered after driving it around town the past couple days.


1: My idiot lights have never worked since i bought the car. noticed one bulb was burnt and the other was missing. I replaced the bulbs and they now both work with the key in ignition on. the GEN/FAN light will dimly stay on and will get brighter as i accelerate, all the time, every time.


2: I have an oil pressure gauge hooked up with the corvair adapt a bolt on top of the oil filter. on startup idle. it reads about 30PSI. after warming the car up on a 20 minute drive or so the pressure will drop pretty low. sometimes even show 0-3 on the gauge. hoping to confirm with a different gauge soon. oil is amsoil z rod 10w-30 from clarks with clarks filter.

3: My longest drive with the car so far has been about 30 minutes of street driving and the car/weather was pretty hot and the TEMP/Pres gauge illuminated. i immediately pulled over and let the car sit for a couple minutes. and when restarted light was off. 5 minutes later down the road it came back on sad smiley but the car drove perfectly. idled smoothly and quietly.Also, oil pressure sender is new from clarks.


anybody swap out the head temp sender/switch completely to install a temp gauge sender? i care more to have a gauge than a very vague light come on

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: MattNall ()
Date: June 10, 2019 10:24PM

Congrats! I knew you get it done!

1 Gen. is not charging properly. Voltmeter on battery posts....rev engine to 2k rpm

Voltage should rise to 13.6 or higher..

2 No lifter clacking? No problem... Lifters clatter at 7 psi usually. You have thin oil...don't worry.

3 Temp switches decay the temp it switches on at with age and heat cycles... get a new one.

MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo




Edited 1 time(s). Last edit at 06/21/2019 07:15AM by MattNall.

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: AKcorvair ()
Date: June 10, 2019 10:45PM

MattNall Wrote:
-------------------------------------------------------
> Congrats! I knew you get it done!
>
> 1 Gen. is not charging properly. Voltmeter on battery posts....rev engine to 2k rpm
>
> Voltage should rise to 13.6 or higher..
>
> 2 No lifter clacking? No problem... Lifters clatter at 7 psi usually. You have thin oil...don't worry.
>
> 3 Temp switches decay the temp it switches on at with age and heat cycles... get a new one.



Thank you!!

Great reply! I will check out the voltage tomorrow while revving.



Edited 1 time(s). Last edit at 06/10/2019 10:48PM by MattNall.

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: Curtis ()
Date: June 11, 2019 12:08PM

20k rpm eh Matt? Watch it explode into a million tiny pieces. lol

Curtis

Milwaukee, Wi

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: joelsplace ()
Date: June 11, 2019 12:09PM

I was wishing mine would run half that.

Joel
Northlake, TX
4 Ultravans, Lost count at 100 Corvairs...

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: AKcorvair ()
Date: June 20, 2019 10:39PM

So I just tested the bolts at the battery. Was 12.3x at idle. Revved it up and did not change.


Clearly my generator is not going its job.

Any recommendations? Repair? Find a rebuilt unit? Alternator conversion?

Would really love to keep costs low on this one.

Any other tests for the generator to see if it’s something simple like changing the brushes etc...


Thank you!

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: MattNall ()
Date: June 20, 2019 11:21PM

In our FAQ's / Electical "How to Motor a generator"

MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: idiyaught ()
Date: June 21, 2019 05:29AM

Could this be a generator that was not polarised?

John Oostdyk
Thornhill, Ont
63 Rampy
65 Greenbrier
64 Convertible

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: MattNall ()
Date: June 21, 2019 07:19AM

idiyaught Wrote:
-------------------------------------------------------
> Could this be a generator that was not polarized?

=============================

Good one!! I missed that! Also in our FAQ's

MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: AKcorvair ()
Date: June 21, 2019 12:19PM

I will try to polarize and motor it today. Is it better to obviously remove the belt before doing so?

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: MattNall ()
Date: June 21, 2019 12:46PM

Polarize FIRST....


If that doesn't fix it... then remove belt and try to motor the gen.

MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote
Re: Shes finally on the road! with other problems....
Posted by: AKcorvair ()
Date: June 26, 2019 01:30PM

Tried to polarize and didn’t fix. Gen light still on very dimly at idle and gets brighter as rpm increases

Will take belt off and motor it.

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.