Corvair DiagramCorvair Photo
Corvair Center
home forum corvairs calendar links Corvair Podcast
California Corvairs
Clarks Corvair
Clarks Corvair
“CORSA"



Chevy Corvair License Plate
Chevy Corvair Chrome Wheel
Corvair Center Forum :  Corvair Center Phorum The fastest message board... ever.
Corvair Center 
Thank You !!
Posted by: Ron62 ()
Date: February 09, 2019 02:49PM

Today was a great day!! I fired up my 67 110 on the engine stand. Started up the first try. Set the timing and let it run for 60 minutes then shut down for an hour then let it run for another 60 minutes. No leaks to report, cold valve adjustment worked out great. TSP distributor and Airtex fuel pump equipped.

The engine was in great shape inside but total disaster everywhere else. Original everything. Seals and all. Engine was covered in oil on every possible surface. Seals were brittle. Main seals were hard as a rock and pouring oil out. With the help of many people on this forum and reading through dozens of posts, I was able to rebuild the engine with the exception of the crank and cam. This being my first Corvair, I very much appreciated all the support from the members here.

Now that the engine is good to go, I can move on to the rest of the car. Thank again to everyone and look forward to more great interaction !!!

Regards
Ron

Options: ReplyQuote
Re: Thank You !!
Posted by: MattNall ()
Date: February 09, 2019 03:08PM

Congrats!! That's why we are here!





MODERATOR
Sea Mountain, between Charleston Harbor and Coos Bay! SW Oregon Coast
Click HERE for My Website...Click HERE for My TechPages!
..............................110-PG.................................................Webered-Turbo

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.